You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

dependencies.md 2.5KB

Dependencies

These are the dependencies currently used by Bitcoin Core. You can find instructions for installing them in the build-*.md file for your platform.

| Dependency | Version used | Minimum Required | CVEs? | Shared | Bundled Qt Library | | --- | --- | --- | --- | --- | --- | --- | | openssl | [1.0.1k]](https://www.openssl.org/source) | | Yes | | | | ccache | 3.3.4 | | No | | | | libevent | 2.1.8-stable | 2.0.22 | No | | | | Qt | 5.7.1 | 4.7+ | No | | | | Freetype | 2.7.1 | | No | | | | Boost | 1.64.0 | 1.47.0 | No | | | | Protobuf | 2.6.3 | | No | | | | Zeromq | 4.1.5 | | No | | | | miniupnpc | 2.0.20170509 | | No | | | | qrencode | 3.4.4 | | No | | | | berkeley-db | 4.8.30 | 4.8.x | No | | | | dbus | 1.10.18 | | No | yes | | | expat | 2.2.1 | | No | yes | | | fontconfig | 2.12.1 | | No | yes | | | freetype | | | | | no (linux uses system) | | zlib | 1.2.11 | | | | no | | libjpeg | | | | | yes | | libpng | | | | | yes | | PCRE | | | | | yes | | xcb | | | | | yes (linux only) | | xkbcommon | | | | | yes (linux only) | | HarfBuzz-NG | | | | | ? | | Python (tests) | | 3.4 | | | | | GCC | | 4.7+ | | | | | Clang | | 3.3+ (C++11 support) | | | |