Browse Source

[Docs] Bump minimum required version of GCC to 4.8

pull/3/head
fanquake 5 years ago
parent
commit
fae98f66fe
No known key found for this signature in database
GPG Key ID: 2EEB9F5CC09526C1
  1. 2
      doc/dependencies.md
  2. 5
      doc/release-notes.md

2
doc/dependencies.md

@ -13,7 +13,7 @@ These are the dependencies currently used by Bitcoin Core. You can find instruct @@ -13,7 +13,7 @@ These are the dependencies currently used by Bitcoin Core. You can find instruct
| Expat | [2.2.1](https://libexpat.github.io/) | | No | Yes | |
| fontconfig | [2.12.1](https://www.freedesktop.org/software/fontconfig/release/) | | No | Yes | |
| FreeType | [2.7.1](http://download.savannah.gnu.org/releases/freetype) | | No | | |
| GCC | | [4.7+](https://gcc.gnu.org/) | | | |
| GCC | | [4.8+](https://gcc.gnu.org/) | | | |
| HarfBuzz-NG | | | | | |
| libevent | [2.1.8-stable](https://github.com/libevent/libevent/releases) | 2.0.22 | No | | |
| libjpeg | | | | | [Yes](https://github.com/bitcoin/bitcoin/blob/master/depends/packages/qt.mk#L75) |

5
doc/release-notes.md

@ -56,6 +56,11 @@ frequently tested on them. @@ -56,6 +56,11 @@ frequently tested on them.
Notable changes
===============
GCC 4.8.x
--------------
The minimum version of GCC required to compile Bitcoin Core is now 4.8. No effort will be
made to support older versions of GCC. See discussion in issue #11732 for more information.
HD-wallets by default
---------------------
Due to a backward-incompatible change in the wallet database, wallets created

Loading…
Cancel
Save