Browse Source

secp256k1: add libtool as a dependency

tags/v0.15.1
Cory Fields 6 years ago
parent
commit
b150b09edc
5 changed files with 8 additions and 2 deletions
  1. 3
    0
      autogen.sh
  2. 1
    0
      configure.ac
  3. 1
    0
      contrib/debian/control
  4. 1
    0
      contrib/gitian-descriptors/gitian-osx-bitcoin.yml
  5. 2
    2
      doc/build-osx.md

+ 3
- 0
autogen.sh View File

@@ -2,4 +2,7 @@
set -e
srcdir="$(dirname $0)"
cd "$srcdir"
if [ -z ${LIBTOOLIZE} ] && GLIBTOOLIZE="`which glibtoolize 2>/dev/null`"; then
export LIBTOOLIZE="${GLIBTOOLIZE}"
fi
autoreconf --install --force

+ 1
- 0
configure.ac View File

@@ -9,6 +9,7 @@ define(_COPYRIGHT_YEAR, 2014)
AC_INIT([Bitcoin Core],[_CLIENT_VERSION_MAJOR._CLIENT_VERSION_MINOR._CLIENT_VERSION_REVISION],[info@bitcoin.org],[bitcoin])
AC_CONFIG_AUX_DIR([src/build-aux])
AC_CONFIG_MACRO_DIR([src/m4])
LT_INIT([disable-shared])
AC_CANONICAL_HOST
AH_TOP([#ifndef BITCOIN_CONFIG_H])
AH_TOP([#define BITCOIN_CONFIG_H])

+ 1
- 0
contrib/debian/control View File

@@ -6,6 +6,7 @@ Uploaders: Micah Anderson <micah@debian.org>
Build-Depends: debhelper,
devscripts,
automake,
libtool,
bash-completion,
libboost-system-dev (>> 1.35) | libboost-system1.35-dev,
libdb4.8++-dev,

+ 1
- 0
contrib/gitian-descriptors/gitian-osx-bitcoin.yml View File

@@ -11,6 +11,7 @@ packages:
- "bsdmainutils"
- "pkg-config"
- "p7zip-full"
- "libtool"

reference_datetime: "2013-06-01 00:00:00"
remotes:

+ 2
- 2
doc/build-osx.md View File

@@ -41,7 +41,7 @@ Instructions: MacPorts

### Install dependencies

sudo port install boost db48@+no_java openssl miniupnpc autoconf pkgconfig automake
sudo port install boost db48@+no_java openssl miniupnpc autoconf pkgconfig automake libtool

Optional: install Qt4

@@ -69,7 +69,7 @@ Instructions: Homebrew

#### Install dependencies using Homebrew

brew install autoconf automake berkeley-db4 boost miniupnpc openssl pkg-config protobuf qt
brew install autoconf automake libtool berkeley-db4 boost miniupnpc openssl pkg-config protobuf qt

Note: After you have installed the dependencies, you should check that the Homebrew installed version of OpenSSL is the one available for compilation. You can check this by typing


Loading…
Cancel
Save