Browse Source

Cleanup on doc/build-unix.txt

pull/1/head
osmosis 10 years ago committed by Shen
parent
commit
a21bdda7ad
  1. 39
      doc/build-unix.txt

39
doc/build-unix.txt

@ -28,7 +28,6 @@ Dependencies @@ -28,7 +28,6 @@ Dependencies
libdb4.8 Berkeley DB Blockchain & wallet storage
libboost Boost C++ Library
miniupnpc UPnP Support Optional firewall-jumping support
libqrencode QRCode generation Optional QRCode generation
miniupnpc may be used for UPnP port mapping. It can be downloaded from
http://miniupnp.tuxfamily.org/files/. UPnP support is compiled in and
@ -37,13 +36,7 @@ turned off by default. Set USE_UPNP to a different value to control this: @@ -37,13 +36,7 @@ turned off by default. Set USE_UPNP to a different value to control this:
USE_UPNP=0 (the default) UPnP support turned off by default at runtime
USE_UPNP=1 UPnP support turned on by default at runtime
libqrencode may be used for QRCode image generation. It can be downloaded
from http://fukuchi.org/works/qrencode/index.html.en, or installed via
your package manager. Set USE_QRCODE to control this:
USE_QRCODE=0 (the default) No QRCode support - libqrcode not required
USE_QRCODE=1 QRCode support enabled
IPv6 support may be enabled by setting
IPv6 support may be enabled by setting:
USE_IPV6=1 Enable IPv6 support
Licenses of statically linked libraries:
@ -61,15 +54,27 @@ Versions used in this release: @@ -61,15 +54,27 @@ Versions used in this release:
Dependency Build Instructions: Ubuntu & Debian
----------------------------------------------
sudo apt-get install build-essential
sudo apt-get install libssl-dev
sudo apt-get install libdb4.8-dev
sudo apt-get install libdb4.8++-dev
Boost 1.40+: sudo apt-get install libboost-all-dev
or Boost 1.37: sudo apt-get install libboost1.37-dev
sudo apt-get install libqrencode-dev
If using Boost 1.37, append -mt to the boost libraries in the makefile.
Build requirements:
sudo apt-get install build-essential
sudo apt-get install libssl-dev
for Ubuntu 12.04:
sudo apt-get install libboost-all-dev
db4.8 packages are available at:
https://launchpad.net/~bitcoin/+archive/bitcoin
Ubuntu precise has packages for libdb5.1-dev and libdb5.1++-dev,
but using these will break binary wallet compatibility, and is not recommended.
for other Ubuntu & Debian:
sudo apt-get install libdb4.8-dev
sudo apt-get install libdb4.8++-dev
sudo apt-get install libboost1.37-dev
(If using Boost 1.37, append -mt to the boost libraries in the makefile)
Optional:
sudo apt-get install libminiupnpc-dev (see USE_UPNP compile flag)
Dependency Build Instructions: Gentoo

Loading…
Cancel
Save