Browse Source

doc: update deps in build-unix.md after libevent

Add libevent, change usage of libssl from "secure communication" to
"crypto" that's more accurate after RPC SSL support removed.
pull/1/head
Wladimir J. van der Laan 7 years ago
parent
commit
1e700c9b60
  1. 7
      doc/build-unix.md

7
doc/build-unix.md

@ -31,8 +31,9 @@ These dependencies are required: @@ -31,8 +31,9 @@ These dependencies are required:
Library | Purpose | Description
------------|------------------|----------------------
libssl | SSL Support | Secure communications
libboost | Boost | C++ Library
libssl | Crypto | Random Number Generation, Elliptic Curve Cryptography
libboost | Utility | Library for threading, data structures, etc
libevent | Networking | OS independent asynchronous networking
Optional dependencies:
@ -57,7 +58,7 @@ Dependency Build Instructions: Ubuntu & Debian @@ -57,7 +58,7 @@ Dependency Build Instructions: Ubuntu & Debian
----------------------------------------------
Build requirements:
sudo apt-get install build-essential libtool autotools-dev autoconf pkg-config libssl-dev
sudo apt-get install build-essential libtool autotools-dev autoconf pkg-config libssl-dev libevent-dev
For Ubuntu 12.04 and later or Debian 7 and later libboost-all-dev has to be installed:

Loading…
Cancel
Save