Browse Source

build: fix qt.conf case-sensitivity in the deployed dmg

For qt5.2 on osx, the qcocoa plugin is mandatory. However, it fails to load
when qt.conf specifies the "plugin" path instead of the expected "Plugin". This
is in line with the documentation:
https://qt-project.org/doc/qt-5.0/qtdoc/qt-conf.html

I'm not sure how the plugins were loading before, unless the case-sensitivity
for OSX is new.
pull/1/head
Cory Fields 9 years ago
parent
commit
0f21d39ffa
  1. 4
      contrib/macdeploy/macdeployqtplus

4
contrib/macdeploy/macdeployqtplus

@ -426,8 +426,8 @@ def deployPlugins(appBundleInfo, deploymentInfo, strip, verbose): @@ -426,8 +426,8 @@ def deployPlugins(appBundleInfo, deploymentInfo, strip, verbose):
deployFrameworks([dependency], appBundleInfo.path, destinationPath, strip, verbose, deploymentInfo)
qt_conf="""[Paths]
translations=Resources
plugins=PlugIns
Translations=Resources
Plugins=PlugIns
"""
ap = ArgumentParser(description="""Improved version of macdeployqt.

Loading…
Cancel
Save