#73 SMTP issues on premium account

Closed
opened 2 years ago by Ghost · 6 comments
Ghost commented 2 years ago

@Uncled1023 All of a sudden (after you’ve gone on vacation), outbound emails seem to be cut back to 100/day (or some kind of limit) on a premium account.

Using rss2email to send RSS feeds to email using Teknik’s server, has been working OK. But now, after some emails sent in a row, I get many errors in rss2email like these two:

SMTPServerDisconnected: please run connect() first
SMTPServerDisconnected: Connection unexpectedly closed

It’s normal to get around 50 new RSS feeds a day which make 50 individual sent emails.

Another reference about the same issue on Gmail here.

When this happens, I can no longer manually compose and send individual emails (SMTP null error), as well. This is not good.

I would use rss2email’s function of sending them through usr/sbin/sendmail which wouldn’t use the SMTP server at all, but unfortunately, your spam filters are not friendly enough and send a lot of genuine emails to the spam folder when the sender email is not from teknik.io.

@Uncled1023 All of a sudden (after you've gone on vacation), outbound emails seem to be cut back to 100/day (or some kind of limit) on a premium account. Using rss2email to send RSS feeds to email using Teknik's server, has been working OK. But now, after some emails sent in a row, I get many errors in rss2email like these two: ```nohighlight SMTPServerDisconnected: please run connect() first SMTPServerDisconnected: Connection unexpectedly closed ``` It's normal to get around 50 new RSS feeds a day which make 50 individual sent emails. Another reference about the same issue on Gmail [here](https://stackoverflow.com/questions/34259004/flask-mail-error-smtpserverdisconnectedplease-run-connect-first). When this happens, I can no longer manually compose and send individual emails (SMTP null error), as well. This is not good. I would use rss2email's function of sending them through `usr/sbin/sendmail` which wouldn't use the SMTP server at all, but unfortunately, your spam filters are not friendly enough and send a lot of genuine emails to the spam folder when the sender email is not from `teknik.io`.
Ghost changed title from SMTP email sending issues to SMTP issues 2 years ago
Ghost changed title from SMTP issues to SMTP Issues on Premium Account 2 years ago
Ghost changed title from SMTP Issues on Premium Account to SMTP issues on premium account 2 years ago
Zero3K commented 2 years ago

It seems to be related to issue #53.

It seems to be related to issue #53.
Ghost commented 2 years ago
Poster

Hmm, not sure. That issue is 6 months old while this just started to happen recently, after I upgraded to premium. I know basic accounts are limited to 100 emails a day but premium are unlimited.

I switched to sending emails by sendmail, which I actually prefer since it’s faster. and I’m not getting any spam false positives lately.

Just now, I switched to SMTP again and I’ll keep an eye on it. Anyway, I’ll probably switch back to sendmail and eventually close this issue although this should be fixed anyway.

Hmm, not sure. That issue is 6 months old while this just started to happen recently, after I upgraded to premium. I know basic accounts are limited to 100 emails a day but premium are [unlimited](https://about.teknik.io). I switched to sending emails by `sendmail`, which I actually prefer since it's faster. ~~and I'm not getting any spam false positives lately~~. Just now, I switched to SMTP again and I'll keep an eye on it. Anyway, I'll probably switch back to `sendmail` ~~and eventually close this issue~~ although this should be fixed anyway.
Ghost commented 2 years ago
Poster

I just tested it and keep getting the same errors. SMTP is still having problems.

I just tested it and keep getting the same errors. SMTP is still having problems.
Ghost commented 2 years ago
Poster
There is no content yet.
Uncled1023 commented 1 year ago
Owner

As Zero3K mentioned, it is due to issue #53.

As Zero3K mentioned, it is due to issue #53.
Uncled1023 added the
Bug
label 1 year ago
Ghost commented 1 year ago
Poster

OK, good call guys. So I’m closing this one since it’s related to the latency issue.

OK, good call guys. So I'm closing this one since it's related to the latency issue.
Sign in to join this conversation.
No Milestone
No Assignees
3 Participants
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
Cancel
Save
There is no content yet.