#53 Server sends Reset packet sporadically

Закрыто
открыта 2 лет назад Uncled1023 · комментариев: 10
Uncled1023 прокомментировал 2 лет назад

Due to high latency, the IIS server is sometimes sending reset packets to close connections due to the Timer_MinBytesPerSecond being hit. This is controlled by the setting minBytesPerSecond which defaults to 240 bytes. For some reason, setting this to 0 is not being used by IIS.

Due to high latency, the IIS server is sometimes sending reset packets to close connections due to the Timer_MinBytesPerSecond being hit. This is controlled by the setting minBytesPerSecond which defaults to 240 bytes. For some reason, setting this to 0 is not being used by IIS.
Uncled1023 прокомментировал 2 лет назад
Владелец
Created question threads in ServerFault and Technet. [https://serverfault.com/questions/846574/iis-10-not-respecting-minbytespersecond-option-in-applicationhost-config](https://serverfault.com/questions/846574/iis-10-not-respecting-minbytespersecond-option-in-applicationhost-config) [https://forums.iis.net/t/1235830.aspx?minBytesPerSecond+webLimit+setting+not+taking+effect](https://forums.iis.net/t/1235830.aspx?minBytesPerSecond+webLimit+setting+not+taking+effect) [https://social.technet.microsoft.com/Forums/en-US/5edc121b-9191-4535-a6aa-ee02a7acc978/iis-10-not-respecting-minbytespersecond-option-in-applicationhostconfig?forum=ws2016](https://social.technet.microsoft.com/Forums/en-US/5edc121b-9191-4535-a6aa-ee02a7acc978/iis-10-not-respecting-minbytespersecond-option-in-applicationhostconfig?forum=ws2016)
Ghost прокомментировал 2 лет назад

The author of this post says:

(…) Secondly, although it is possible to reduce the minBytesPerSecond, as shown in Figure 2, it may just postpone the problem into the future. However, in a critical situation, give it shot. NOTE: if you set the value to 0, then the check is disabled.

The author of [this](https://blogs.msdn.microsoft.com/benjaminperkins/2013/02/01/its-not-iis/) post says: > (...) Secondly, although it is possible to reduce the `minBytesPerSecond`, as shown in Figure 2, it may just postpone the problem into the future. However, in a critical situation, give it shot. NOTE: if you set the value to 0, then the check is disabled.
Uncled1023 прокомментировал 2 лет назад
Владелец

Yea, I have tried that as well, no potatoes…

Yea, I have tried that as well, no potatoes...
Ghost прокомментировал 2 лет назад

I guess I understood it wrong. I thought that setting it to 0 would not have any effect (disabled) and that the required minimum value would be 1.

I guess I understood it wrong. I thought that setting it to `0` would not have any effect (disabled) and that the required minimum value would be `1`.
Uncled1023 прокомментировал 2 лет назад
Владелец

Still trying to solve this. Currently not advertising the site due to this, as this issue is seriously degrading the experience of the site.

Still trying to solve this. Currently not advertising the site due to this, as this issue is seriously degrading the experience of the site.
Zero3K прокомментировал 2 лет назад

I don’t think its solvable.

I don't think its solvable.
Uncled1023 прокомментировал 2 лет назад
Владелец

Another update. I did some messing with config settings, and set the minBytesPerSecond config very high (about 1 MB), and noticed something interesting. The Timer_MinBytesPerSecond were now mentioning the actual upload file that was throwing the error. This is making me think that the IIS minBytesPerSecond is actually working correctly, but the Timer_MinBytesPerSecond is being thrown from something else, as they are not specifying any specific page.

Another update. I did some messing with config settings, and set the minBytesPerSecond config very high (about 1 MB), and noticed something interesting. The Timer_MinBytesPerSecond were now mentioning the actual upload file that was throwing the error. This is making me think that the IIS minBytesPerSecond is actually working correctly, but the Timer_MinBytesPerSecond is being thrown from something else, as they are not specifying any specific page.
Uncled1023 прокомментировал 2 лет назад
Владелец

Ok, so after some more digging, I think I found the ‘fix’. HTTP/2. Once I disabled that, it seems to be working correctly. :D

Please test this yourselves and let me know if you are still having issues.

Ok, so after some more digging, I think I found the 'fix'. HTTP/2. Once I disabled that, it seems to be working correctly. :D Please test this yourselves and let me know if you are still having issues.
Ghost прокомментировал 2 лет назад

Just tested it out, using Teknik’s SMTP server, and I got no error messages sending around 175 emails (RSS feeds) to my own email. No issues so far, so this seems fixed to me. =]

Nevertheless I’ll be using sendmail to a Roundcube email account until I can get inline styles properly rendered in Rainloop.

Just tested it out, using Teknik's SMTP server, and I got no error messages sending around 175 emails (RSS feeds) to my own email. No issues so far, so this seems fixed to me. =] Nevertheless I'll be using `sendmail` to a Roundcube email account until I can get inline styles [properly rendered in Rainloop](https://git.teknik.io/Teknikode/Teknik/issues/75).
Uncled1023 прокомментировал 2 лет назад
Владелец

Closing as the issue is gone, will re-open if I need to upgrade to HTTP/2 and test things

Closing as the issue is gone, will re-open if I need to upgrade to HTTP/2 and test things
Войдите, чтобы присоединиться к обсуждению.
Нет этапа
Нет назначенных лиц
3 участников
Срок выполнения

Срок выполнения не установлен.

Зависимости

В настоящее время эта задача не имеет зависимостей.

Загрузка…
Отмена
Сохранить
Пока нет содержимого.