#53 Server sends Reset packet sporadically

Geschlossen
vor 3 Jahren von Uncled1023 geöffnet · 10 Kommentare
Uncled1023 hat vor 3 Jahren kommentiert

Due to high latency, the IIS server is sometimes sending reset packets to close connections due to the Timer_MinBytesPerSecond being hit. This is controlled by the setting minBytesPerSecond which defaults to 240 bytes. For some reason, setting this to 0 is not being used by IIS.

Due to high latency, the IIS server is sometimes sending reset packets to close connections due to the Timer_MinBytesPerSecond being hit. This is controlled by the setting minBytesPerSecond which defaults to 240 bytes. For some reason, setting this to 0 is not being used by IIS.
Uncled1023 hat vor 3 Jahren kommentiert
Besitzer
Created question threads in ServerFault and Technet. [https://serverfault.com/questions/846574/iis-10-not-respecting-minbytespersecond-option-in-applicationhost-config](https://serverfault.com/questions/846574/iis-10-not-respecting-minbytespersecond-option-in-applicationhost-config) [https://forums.iis.net/t/1235830.aspx?minBytesPerSecond+webLimit+setting+not+taking+effect](https://forums.iis.net/t/1235830.aspx?minBytesPerSecond+webLimit+setting+not+taking+effect) [https://social.technet.microsoft.com/Forums/en-US/5edc121b-9191-4535-a6aa-ee02a7acc978/iis-10-not-respecting-minbytespersecond-option-in-applicationhostconfig?forum=ws2016](https://social.technet.microsoft.com/Forums/en-US/5edc121b-9191-4535-a6aa-ee02a7acc978/iis-10-not-respecting-minbytespersecond-option-in-applicationhostconfig?forum=ws2016)
Ghost hat vor 3 Jahren kommentiert

The author of this post says:

(…) Secondly, although it is possible to reduce the minBytesPerSecond, as shown in Figure 2, it may just postpone the problem into the future. However, in a critical situation, give it shot. NOTE: if you set the value to 0, then the check is disabled.

The author of [this](https://blogs.msdn.microsoft.com/benjaminperkins/2013/02/01/its-not-iis/) post says: > (...) Secondly, although it is possible to reduce the `minBytesPerSecond`, as shown in Figure 2, it may just postpone the problem into the future. However, in a critical situation, give it shot. NOTE: if you set the value to 0, then the check is disabled.
Uncled1023 hat vor 3 Jahren kommentiert
Besitzer

Yea, I have tried that as well, no potatoes…

Yea, I have tried that as well, no potatoes...
Ghost hat vor 3 Jahren kommentiert

I guess I understood it wrong. I thought that setting it to 0 would not have any effect (disabled) and that the required minimum value would be 1.

I guess I understood it wrong. I thought that setting it to `0` would not have any effect (disabled) and that the required minimum value would be `1`.
Uncled1023 hat vor 3 Jahren kommentiert
Besitzer

Still trying to solve this. Currently not advertising the site due to this, as this issue is seriously degrading the experience of the site.

Still trying to solve this. Currently not advertising the site due to this, as this issue is seriously degrading the experience of the site.
Zero3K hat vor 3 Jahren kommentiert

I don’t think its solvable.

I don't think its solvable.
Uncled1023 hat vor 3 Jahren kommentiert
Besitzer

Another update. I did some messing with config settings, and set the minBytesPerSecond config very high (about 1 MB), and noticed something interesting. The Timer_MinBytesPerSecond were now mentioning the actual upload file that was throwing the error. This is making me think that the IIS minBytesPerSecond is actually working correctly, but the Timer_MinBytesPerSecond is being thrown from something else, as they are not specifying any specific page.

Another update. I did some messing with config settings, and set the minBytesPerSecond config very high (about 1 MB), and noticed something interesting. The Timer_MinBytesPerSecond were now mentioning the actual upload file that was throwing the error. This is making me think that the IIS minBytesPerSecond is actually working correctly, but the Timer_MinBytesPerSecond is being thrown from something else, as they are not specifying any specific page.
Uncled1023 hat vor 2 Jahren kommentiert
Besitzer

Ok, so after some more digging, I think I found the ‘fix’. HTTP/2. Once I disabled that, it seems to be working correctly. :D

Please test this yourselves and let me know if you are still having issues.

Ok, so after some more digging, I think I found the 'fix'. HTTP/2. Once I disabled that, it seems to be working correctly. :D Please test this yourselves and let me know if you are still having issues.
Ghost hat vor 2 Jahren kommentiert

Just tested it out, using Teknik’s SMTP server, and I got no error messages sending around 175 emails (RSS feeds) to my own email. No issues so far, so this seems fixed to me. =]

Nevertheless I’ll be using sendmail to a Roundcube email account until I can get inline styles properly rendered in Rainloop.

Just tested it out, using Teknik's SMTP server, and I got no error messages sending around 175 emails (RSS feeds) to my own email. No issues so far, so this seems fixed to me. =] Nevertheless I'll be using `sendmail` to a Roundcube email account until I can get inline styles [properly rendered in Rainloop](https://git.teknik.io/Teknikode/Teknik/issues/75).
Uncled1023 hat vor 2 Jahren kommentiert
Besitzer

Closing as the issue is gone, will re-open if I need to upgrade to HTTP/2 and test things

Closing as the issue is gone, will re-open if I need to upgrade to HTTP/2 and test things
Uncled1023 hat vor 2 Jahren geschlossen
Anmelden, um an der Diskussion teilzunehmen.
Kein Meilenstein
Niemand zuständig
3 Beteiligte
Fällig am

Kein Fälligkeitsdatum gesetzt.

Abhängigkeiten

Dieses Issue hat momentan keine Abhängigkeiten.

Laden…
Abbrechen
Speichern
Hier gibt es bis jetzt noch keinen Inhalt.