A python library for interacting with Teknik Services
Vous ne pouvez pas sélectionner plus de 25 sujets Les noms de sujets doivent commencer par une lettre ou un nombre, peuvent contenir des tirets ('-') et peuvent comporter jusqu'à 35 caractères.

setup.py 2.5KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576
  1. # Always prefer setuptools over distutils
  2. from setuptools import setup, find_packages
  3. # To use a consistent encoding
  4. from codecs import open
  5. from os import path
  6. here = path.abspath(path.dirname(__file__))
  7. # Get the long description from the README file
  8. with open(path.join(here, 'README.rst'), encoding='utf-8') as f:
  9. long_description = f.read()
  10. setup(
  11. name='Teknik',
  12. # Versions should comply with PEP440. For a discussion on single-sourcing
  13. # the version across setup.py and the project code, see
  14. # https://packaging.python.org/en/latest/single_source_version.html
  15. version='1.0.5',
  16. description='A library for using the Teknik Services',
  17. long_description=long_description,
  18. # The project's main homepage.
  19. url='https://git.teknik.io/Teknikode/Tools/src/master/Python',
  20. # Author details
  21. author='Uncled1023',
  22. author_email='admin@teknik.io',
  23. # Choose your license
  24. license='BSD 3-Clause',
  25. # See https://pypi.python.org/pypi?%3Aaction=list_classifiers
  26. classifiers=[
  27. # How mature is this project? Common values are
  28. # 3 - Alpha
  29. # 4 - Beta
  30. # 5 - Production/Stable
  31. 'Development Status :: 3 - Alpha',
  32. # Indicate who your project is intended for
  33. 'Intended Audience :: Developers',
  34. 'Topic :: Software Development :: Libraries',
  35. # Pick your license as you wish (should match "license" above)
  36. 'License :: OSI Approved :: BSD License',
  37. # Specify the Python versions you support here. In particular, ensure
  38. # that you indicate whether you support Python 2, Python 3 or both.
  39. 'Programming Language :: Python :: 3',
  40. 'Programming Language :: Python :: 3.3',
  41. 'Programming Language :: Python :: 3.4',
  42. 'Programming Language :: Python :: 3.5',
  43. 'Programming Language :: Python :: 3 :: Only',
  44. ],
  45. # What does your project relate to?
  46. keywords='teknik services upload paste',
  47. # You can just specify the packages manually here if your project is
  48. # simple. Or you can use find_packages().
  49. packages=find_packages(exclude=['contrib', 'docs', 'tests']),
  50. python_requires='>=3',
  51. # Alternatively, if you want to distribute just a my_module.py, uncomment
  52. # this:
  53. # py_modules=["my_module"],
  54. # List run-time dependencies here. These will be installed by pip when
  55. # your project is installed. For an analysis of "install_requires" vs pip's
  56. # requirements files see:
  57. # https://packaging.python.org/en/latest/requirements.html
  58. install_requires=['requests'],
  59. )