Browse Source

Added the eslint dependencies for stricter type checks

main
Navneet Sharma 4 months ago
parent
commit
fe6bcb94bc
  1. 1009
      package-lock.json
  2. 12
      package.json

1009
package-lock.json generated

File diff suppressed because it is too large Load Diff

12
package.json

@ -80,16 +80,22 @@ @@ -80,16 +80,22 @@
"@types/node": "^16.7.2",
"@types/node-fetch": "^2.5.12",
"@types/nprogress": "^0.2.0",
"@typescript-eslint/eslint-plugin": "^4.29.3",
"@typescript-eslint/parser": "^4.29.3",
"@typescript-eslint/eslint-plugin": "^5.14.0",
"@typescript-eslint/parser": "^5.14.0",
"autoprefixer": "^10.3.3",
"cross-env": "^7.0.3",
"cssnano": "^5.0.6",
"cssnano-preset-advanced": "^5.1.4",
"dotenv": "^10.0.0",
"eslint": "^7.22.0",
"eslint-config-airbnb-typescript": "^16.1.0",
"eslint-config-prettier": "^8.1.0",
"eslint-plugin-svelte3": "^3.2.0",
"eslint-import-resolver-typescript": "^2.5.0",
"eslint-plugin-eslint-comments": "^3.2.0",
"eslint-plugin-import": "^2.25.4",
"eslint-plugin-promise": "^6.0.0",
"eslint-plugin-svelte3": "^3.4.1",
"eslint-plugin-tsdoc": "^0.2.14",
"husky": "^7.0.2",
"lint-staged": "^11.1.2",
"node-fetch": "^2.6.1",

Loading…
Cancel
Save